您正在查看: 标签 compiz 下的文章

回滚 Unity 至 Ubuntu 16.04 初始版本

最近 Ubuntu 16.04 推送了一批 Unity 和 Compiz 更新,结果导致自己的 Fractional Scale 功能挂掉了。

已经有人提交了 Bug,不过看起来似乎没人鸟你了。

咋办呢?那只能回滚了,但是回滚 Unity 可没那么容易,依赖太多,还有 Compiz 等核心组件,所以我们要滚只能滚大的了。

33ec6d67d66f5b3c0933d6c5e0ee66c3.gif

阅读全文...

Cry me a river

我很早就用过 Linux,小学的时候发现连声卡驱动都是问题,之后我又一次尝试 Linux 的时候是中学,我发现我记得我单是想看个片儿都得编译一下午安装 Mplayer。我正儿八经第一次发现 Linux 桌面变得“可用”的时候是 2007 年左右,伴随着 Ubuntu 7.04 这个版本的发布,那个版本的代号我记得很清楚叫做 Feistyfawn,所以到了现在我有很多地方还是在用这个代号当作自己的 ID。

当时的 Linux 桌面在现在看来几乎是很臃肿的,Gnome2 的设计对于显示器的纵向空间的利用简直是一场灾难,上面一个顶栏,下面一个任务栏,窗口本身还有一个标题栏,上下一共三个标题栏直接压榨完毕了至少 3 行字的空间,所以到了大概是 Ubuntu 11.04 的时候,Canonical 在自己的发行版里内置了一个 GlobalMenu 的插件,不少人(包括我在内)通过启用这个插件,加上不少现成的 Dock 类软件,不但可以做出类似 Mac OSX 一样的样式效果,并且可以节省出一行的纵向空间。

我记得我但是也是这么做的,不过那时候 Canonical 已经开始强行推广自己的特殊 Windows Manager,那个名叫 Unity 的玩意儿。

值得一提的是 Unity 被设置为默认 Windows Manager 是从那 Ubuntu 11.04 开始的,那时候的 Unity 恕我直言是压根没法用的,也辛苦了当时的图拉丁主席还在坚持用那玩意儿,不过好在你可以轻松的卸载掉 Unity 使用老的 Gnome 2,还继续自带 Global Menu,改改配置用起来美滋滋。

然而之后 Gnome 2 也被干掉了,Fedora 率先强行推广 Gnome 3,那粗大的标题栏,依然浪费的纵向空间,还有强行削减的 Indicator,让很多用户包括我在内都无法接受,而蓦然回首,Ubuntu 12.04 发布了,不少用户突然发现,这 Ubuntu 的 Unity 居然突然变得能用了。

是的,变得能用了,而且比想象中的还要好不少,用多了也逐渐适应了 Unity 的设计思想,侧边 Dock 是为了避免浪费纵向空间,全屏状态下标题栏和顶栏会整合进一步节省纵向空间,而全局菜单依然存在,也就是说原本 Gnome 2 乃至 Gnome 3 对纵向空间的丧心病狂的浪费问题在 Unity 下面得到了妥善的解决。

之后我就一直在用 Unity 了,因为其他的真的没法用,而 Unity 本身随着修修补补也基本没啥稳定性问题,除了你显卡驱动没装好会崩溃以外,但是那也和 Unity 以及背后的 Compiz 没啥关系了。之后 Canonical 宣布了 Unity 8 项目,表示 Unity 8 将会是 Unity 7 的下一代,重点是“移动,桌面,平板”的三者和一,这个理念是比 Windows 10 的大一统观念是要来的早的。

选区_017.png

阅读全文...

解决 Ubuntu 下 Unity 新窗口不能前置的问题

如果你像我一样经常用 Firefox 全屏的话,可能你会遇到我一样的问题。

就是经常在 Firefox 全屏浏览网页的时候,点击其他弹出窗口,窗口会在 Firefox 的下面,不会提升到最前,包括不限于查看 Wifi 状态,新浪微博上传图片等等等。

而且这个情况只出现在 Unity 环境下,很是恶心。

不过现在有方法解决了。

阅读全文...

修复Nvidia显卡闭源驱动下Compiz的闪动问题的补充

UPDATE:compiz patch的PPA已经更新到最新版,所以锁定compiz版本已经没有必要。


写过如何修复Compiz与Nvidia显卡闭源驱动之间的这个bug的方法,结论是使用PPA,然后最近呢,丧心病狂的Compiz升级了,这个PPA的版本被覆盖掉了,于是我赫然发现,那个Bug没修,屏幕又特么开始闪了……

首先想到的是用新立德回滚到PPA版本,但是compiz这玩意依赖太多,直接依赖unity,回滚操作还不能多选,于是只能滚回到有patch的PPA里下载deb,下载完毕后用sudo dpkg -i *.deb一股脑全降级了。

再次打开新立德把所有compiz版本锁定。

菜单_279.png

阅读全文...

Compiz与Nvidia闭源最新驱动的刷新率bug修正

Ubuntu 14.04下,如果你是N卡用户,安装源里的331版本驱动甚至更老的是不会有问题的,但是如果你通过手动,或者PPA安装340以及以上版本驱动的话,会发现系统部分按钮和列表开始乱闪。

经很多用户确定这是一个Compiz的Bug,这里有很多讨论结果,最后的解决方法是打补丁。

Compiz本身的补丁不知道什么时候来,但是你可以试试PPA

ppa:townsend/compiz-nvidia-refresh-test

测试后使用343最新驱动问题解决,显卡是GTX770 4G

选区\_936.png

阅读全文...

相关内容